Forum i Visma SummaSummarum
annuller
Viser resultater for 
Søg i stedet efter 
Mente du: 
CONTRIBUTOR ***

Re: "Send pr e-mail" virker ikke

#John H  -  Ja, super at det hjalp dig.

Bare så meget mere underligt, at det ikke virker på min pc.
Som beskrevet tidligere, og andre steder, bruger jeg allerede Thunderbird (nyeste v. 31.4.0)
- og har Outlook 2013 installeret på denne pc, selvom jeg ikke bruger den som standardprogram.

Og skifter jeg funktionalitet og indsætter Outlook 2013 som standardprogram, i stedet for TB,
så hjælper det heller ikke noget. Den vej er prøvet i flere omgange.

CONTRIBUTOR ***

Re: "Send pr e-mail" virker ikke

Hej Alle

Er i konstruktiv dialog med SummaSummarum's support, og kan umidddelbart videregive, at de også konkluderer at MAPI-fejlen tilsyneladende opstår som en direkte følge af af-installation af MS Office. Både version 2007, 2010 og 2013. En af-installation fjerner åbenbart (mindst) en betydende nøgleværdi i windows' registreringsdatabase, hvorefter Summa's "kald" til MAPI-klienten ikke gennemføres korrekt. 

Har uden held testet at genoprette overensstemmelsen, idet Summa's support vejledte mig til oprettelse af den registernøgle-værdi som de havde fundet manglede. Jeg kunne konstatere at denne registernøgle ganske rigtigt manglede på min pc med MAPI-fejlen. Desværre løste den ene nøgle ikke umiddelbart MAPI-problemet.

Der arbejdes fortsat på en løsning.

Selvfølgelig vil jeg tilstræbe at videregive brugbare nyheder i denne tråd
- hav tålmodighed.

Highlighted

Re: "Send pr e-mail" virker ikke

Re: "Send pr e-mail" virker ikke

Funktionaliteten ved afsendelse af mail, ser nogenlunde sådan ud:

Først tester vi på om Windows understøtter ExtendedMapi eller SimpleMapi, hvis ingen af delene understøttes returneres fejl.

Hvis der understøttes ExtendedMapi og standard-mail klienten er sat til Microsoft Outlook, anvendes Microsoft Outlook COM interface til at sende en mail via Outlook. Dette er lavet for at understøtte Outlook standard signatur og HTML formattering hvis dette er valgt, når man sender mails.

Hvis ExtendedMapi ikke understøttes, eller standard klienten er noget andet end Microsoft Outlook, anvendes SimpleMapi interface til afsendelse af mails. Dette interface understøttes bla af Windows Live Mail, Outlook Express og Mozilla Thunderbird.

Når det nu ikke virker - og nu kan det godt blive lidt teknisk

Det sprog som SummaSummarum er programmeret i, indeholder standard funktioner til at sende mail via SimpleMAPI. Disse funktioner er lavet, så de tjekker om en bestemt nøgle findes i registreringsdatabasen, inden de prøver at indlæse MAPI32.DLL. Findes nøglen ikke, betyder det at SimpleMAPI ikke er tilgængelig, og der kan ikke sendes mail.

Det er konstateret at nogle versioner af Microsofts Office installationsprogram fjerner en bestemt nøgle i registreringsdatabasen, når man afinstallerer Office pakken. 

Nøglen bliver sat, når Windows installeres, og fortæller at MAPI er understøttet - og at MAPI32.DLL er tilgængelig på systemet. Denne DLL anvendes, når der sendes mails via SimpleMAPI.

Årsagen til at den sættes allerede ved installation af Windows er at Windows i sig selv understøtter SimpleMAPI, det må derfor betegnes som en fejl at Office installationsprogrammerne fjerner en nøgle som det ikke har sat selv.

Det fremføres i vores community, at det virker fra andre programmer, men ikke fra SummaSummarum. Årsagen til dette er sandsynligvis, at der ikke først tjekkes i registreringsdatabasen om nøglen er sat, men at man bare indlæser MAPI32.DLL og begynder at sende mails. 

Ind til videre er det konstateret at afinstallation af Office 2013, 2010 og 2007 i 32-bit udgaver, og Office 2010 i 64-bit fjerner nøglen. Tilsyneladende fjernes nøglen kun, hvis man har haft opsat en e-mail konto i Outlook. 

-------

Vi har ikke fået en tilbage melding på om på, om dette også skyldes fejl på kundens PC'er, så løsningen er ikke rigtigt verificeret endnu.

Info om registreringsnøgle

Den registreringsnøgle, som mangler hedder MAPI, og har værdien '1':

Inden man retter i windows registeringsdatabase, bør man tage en sikkerhedskopi

Jeg vil ikke her vise hvordan man retter i windowsregistreringsdatabase, men håber på, at nogen godt ved hvordan man gør og evt. vender tilbage, enten her eller til mig i supporten om det lykkedes eller ej. Jeg er også parat til at logge på en PC'er og lave denne, hvis nogen er usikker på hvordan det gøres.

Den bør ligge under følgende node i registreringsdatabasen:

På en 32-bit udgave af Windows (x32), ligger den under

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows Messaging Subsystem

På en 64-bit udgave (x64), ligger den under

HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows Messaging Subsystem

Vedlagt et billedet på, hvordan det skal se ud på en windows 7/8 64bit

CONTRIBUTOR *

Re: "Send pr e-mail" virker ikke

den nævnte fil ligger på plads præcis der du siger i reg.databasen og værdi 1 og alt - men jeg får stadigt- Not resources enough når jeg vælger send

Vælges thunderbird som standard i stedet for outlook - går alt fint

vh John H

CONTRIBUTOR **

Re: "Send pr e-mail" virker ikke

Tak for info. Så blev man da (igen) klogere Glad humørikon

Re: "Send pr e-mail" virker ikke

@John H

Denne fejl "Not resources enough" har jeg ikke hørt før, så jeg vil lige vide hvilket OS og bit, samt Office og bit du kører med.

Billedet jeg viste, var på en 64bit, og hvis det også er det du kører på, kunne det måske være en ide, også at sætte nøglen i 32bit (hvis den altså ikke er der :-))

@Karsten Madsen

Velbekommen.

De bedste hilsner

Henrik Schytz 

CONTRIBUTOR *

Re: "Send pr e-mail" virker ikke

Win 7  74 it - office 2010 - som sagt med motzilla mail som standard sender det. Jeg ser det nu selv ikke som stort problem jeg gemmer bare sikkerhed og sender fra den mappe de få gange jeg har behovet Glad humørikon 

CONTRIBUTOR *

Re: "Send pr e-mail" virker ikke

@Henrik, tak oprettede MAPI nøglen i registry, så virkede det her.

Windows 10 1809 Outlook 2016-32bit (o365)

 

Mvh

Anders