annuller
Viser resultater for 
Søg i stedet efter 
Mente du: 
Mine områder

Log på eller tilmeld dig som ny bruger

for automatisk at få relevante områder

Allan Andersen
CONTRIBUTOR ***

"Send pr e-mail" virker ikke

af Allan Andersen

At kunne email'e bilag direkte fra SummaSummarum er en vigtig funktion.

Siden opdateringen i februar har jeg ikke kunnet få dette til at virke.

Jf. telefonisk vejledning fra Visma support har jeg geninstalleret både

Summa, email-klient (og skiftet til ny) og nu til sidst en hel pc med ny Win7.

 

Lige lidt har det hjulpet - ingen af mine 3 pc'ere vil længere sende bilag pr email.

Nogen der har lignende problem?

Eller, bedre endnu, en løsning?

 

Mvh Allan Andersen

28SVAR28
Anonymous
Ikke relevant

af Anonymous

Win 7  74 it - office 2010 - som sagt med motzilla mail som standard sender det. Jeg ser det nu selv ikke som stort problem jeg gemmer bare sikkerhed og sender fra den mappe de få gange jeg har behovet 🙂 

af Henrik Schytz

@John H

Denne fejl "Not resources enough" har jeg ikke hørt før, så jeg vil lige vide hvilket OS og bit, samt Office og bit du kører med.

Billedet jeg viste, var på en 64bit, og hvis det også er det du kører på, kunne det måske være en ide, også at sætte nøglen i 32bit (hvis den altså ikke er der :-))

@Karsten Madsen

Velbekommen.

De bedste hilsner

Henrik Schytz 

Karsten Madsen
CONTRIBUTOR **

af Karsten Madsen

Tak for info. Så blev man da (igen) klogere 🙂

Anonymous
Ikke relevant

af Anonymous

den nævnte fil ligger på plads præcis der du siger i reg.databasen og værdi 1 og alt - men jeg får stadigt- Not resources enough når jeg vælger send

Vælges thunderbird som standard i stedet for outlook - går alt fint

vh John H

af Henrik Schytz

Funktionaliteten ved afsendelse af mail, ser nogenlunde sådan ud:

Først tester vi på om Windows understøtter ExtendedMapi eller SimpleMapi, hvis ingen af delene understøttes returneres fejl.

Hvis der understøttes ExtendedMapi og standard-mail klienten er sat til Microsoft Outlook, anvendes Microsoft Outlook COM interface til at sende en mail via Outlook. Dette er lavet for at understøtte Outlook standard signatur og HTML formattering hvis dette er valgt, når man sender mails.

Hvis ExtendedMapi ikke understøttes, eller standard klienten er noget andet end Microsoft Outlook, anvendes SimpleMapi interface til afsendelse af mails. Dette interface understøttes bla af Windows Live Mail, Outlook Express og Mozilla Thunderbird.

Når det nu ikke virker - og nu kan det godt blive lidt teknisk

Det sprog som SummaSummarum er programmeret i, indeholder standard funktioner til at sende mail via SimpleMAPI. Disse funktioner er lavet, så de tjekker om en bestemt nøgle findes i registreringsdatabasen, inden de prøver at indlæse MAPI32.DLL. Findes nøglen ikke, betyder det at SimpleMAPI ikke er tilgængelig, og der kan ikke sendes mail.

Det er konstateret at nogle versioner af Microsofts Office installationsprogram fjerner en bestemt nøgle i registreringsdatabasen, når man afinstallerer Office pakken. 

Nøglen bliver sat, når Windows installeres, og fortæller at MAPI er understøttet - og at MAPI32.DLL er tilgængelig på systemet. Denne DLL anvendes, når der sendes mails via SimpleMAPI.

Årsagen til at den sættes allerede ved installation af Windows er at Windows i sig selv understøtter SimpleMAPI, det må derfor betegnes som en fejl at Office installationsprogrammerne fjerner en nøgle som det ikke har sat selv.

Det fremføres i vores community, at det virker fra andre programmer, men ikke fra SummaSummarum. Årsagen til dette er sandsynligvis, at der ikke først tjekkes i registreringsdatabasen om nøglen er sat, men at man bare indlæser MAPI32.DLL og begynder at sende mails. 

Ind til videre er det konstateret at afinstallation af Office 2013, 2010 og 2007 i 32-bit udgaver, og Office 2010 i 64-bit fjerner nøglen. Tilsyneladende fjernes nøglen kun, hvis man har haft opsat en e-mail konto i Outlook. 

-------

Vi har ikke fået en tilbage melding på om på, om dette også skyldes fejl på kundens PC'er, så løsningen er ikke rigtigt verificeret endnu.

Info om registreringsnøgle

Den registreringsnøgle, som mangler hedder MAPI, og har værdien '1':

Inden man retter i windows registeringsdatabase, bør man tage en sikkerhedskopi

Jeg vil ikke her vise hvordan man retter i windowsregistreringsdatabase, men håber på, at nogen godt ved hvordan man gør og evt. vender tilbage, enten her eller til mig i supporten om det lykkedes eller ej. Jeg er også parat til at logge på en PC'er og lave denne, hvis nogen er usikker på hvordan det gøres.

Den bør ligge under følgende node i registreringsdatabasen:

På en 32-bit udgave af Windows (x32), ligger den under

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows Messaging Subsystem

På en 64-bit udgave (x64), ligger den under

HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows Messaging Subsystem

Vedlagt et billedet på, hvordan det skal se ud på en windows 7/8 64bit

Anonymous
Ikke relevant

af Anonymous

@Anonymous, tak oprettede MAPI nøglen i registry, så virkede det her.

Windows 10 1809 Outlook 2016-32bit (o365)

 

Mvh

Anders

af Henrik Schytz

Allan Andersen
CONTRIBUTOR ***

af Allan Andersen

Hej Alle

Er i konstruktiv dialog med SummaSummarum's support, og kan umidddelbart videregive, at de også konkluderer at MAPI-fejlen tilsyneladende opstår som en direkte følge af af-installation af MS Office. Både version 2007, 2010 og 2013. En af-installation fjerner åbenbart (mindst) en betydende nøgleværdi i windows' registreringsdatabase, hvorefter Summa's "kald" til MAPI-klienten ikke gennemføres korrekt. 

Har uden held testet at genoprette overensstemmelsen, idet Summa's support vejledte mig til oprettelse af den registernøgle-værdi som de havde fundet manglede. Jeg kunne konstatere at denne registernøgle ganske rigtigt manglede på min pc med MAPI-fejlen. Desværre løste den ene nøgle ikke umiddelbart MAPI-problemet.

Der arbejdes fortsat på en løsning.

Selvfølgelig vil jeg tilstræbe at videregive brugbare nyheder i denne tråd
- hav tålmodighed.

Allan Andersen
CONTRIBUTOR ***

af Allan Andersen

#John H  -  Ja, super at det hjalp dig.

Bare så meget mere underligt, at det ikke virker på min pc.
Som beskrevet tidligere, og andre steder, bruger jeg allerede Thunderbird (nyeste v. 31.4.0)
- og har Outlook 2013 installeret på denne pc, selvom jeg ikke bruger den som standardprogram.

Og skifter jeg funktionalitet og indsætter Outlook 2013 som standardprogram, i stedet for TB,
så hjælper det heller ikke noget. Den vej er prøvet i flere omgange.

Karsten Madsen
CONTRIBUTOR **

af Karsten Madsen

Super

Anonymous
Ikke relevant

af Anonymous

installerede thunderbird - gratis mail program - det kører helt fint ved siden af min outlook (åbner det slet ikke normalt men bruge outlook) - satte det til helt samme mail som min outlook bruger - samme IMAP som den så henter fra hvis jeg åbner thunderball

Når jeg så ber summa sende sikkerhed som email  så åbner den fint en mail i thunderbird (også selv om programmet er lukket) og jeg kan sende der fra - og da den kører samme imap som jeg bruger i outlook, ligger den så også i sendt post

Anonymous
Ikke relevant

af Anonymous

@ Karsten Madsen   Jeg som har samme problem bruger win 7 home premium og office 2010    Tak for hjælpen i alle fald

vh John H

Karsten Madsen
CONTRIBUTOR **

af Karsten Madsen

@Bjarne V Nielsen: Hvilken version af Office bruger du ?

 

mvh

Karsten Madsne

Allan Andersen
CONTRIBUTOR ***

af Allan Andersen

Hej Karsten.

Det kan vist være det samme, FOR:

Har netop i dag installeret MS Office 2013 på min (nærmest ny-installerede) bærbare,
I samme moment AF-installerede jeg den MS Office 2007 startpakke som oprindeligt fulgte med,
og som derfor var "genopstået" da jeg lavede en "recovery"-installation af den oprindelige windows7 på pc'en.

BUM - i samme øjeblik ms office 2007 var væk fik jeg den efterhånden velkendte MAPI fejl

Så øjensynlig ER MAPI-funktionaliteten i vores SummaSummarum 4.51 Enterprise altså fuldstændigt afhængig
af et samspil med en gammel MAPI-"motor" i MS Office - måske via Outlook - hvad ved jeg....

Og JO - ALLE mine andre programmer, f.eks. Acrobat Reader XI, kan STADIG fint adressere
min udbakke i Thunderbird via MAPI som før  - KUN og ALENE SummaSummarum fejler.

Hermed er jeg således direkte tilbage ved mit første, andet, tredje, fjerde og femte indlæg:

Denne fejl opstår som følge af programmering af et fejlagtigt MAPI-kald i Summa!

Læser supporten med her? 

Karsten Madsen
CONTRIBUTOR **

af Karsten Madsen

Jeg vil gerne tilbyde at prøve - hvis jeg kan få adgang til en af jeres pc'er

Anonymous
Ikke relevant

af Anonymous

Jeg har også samme problem med mail funktionen.

Meget irreterende!

Hilsen

 

Bjarne V. Nielsen

Karsten Madsen
CONTRIBUTOR **

af Karsten Madsen

Æv, æv

Men det var da forsøge værd ;-(

Allan Andersen
CONTRIBUTOR ***

af Allan Andersen

Hej Karsten M

Testede lige din foreslåede komma-gen-opretnings-procedure på min stationære (den som først havde problemet med MAPI)

Desværre ændrede det ikke på status quo - SummaSum (nu ver. 4.50) vil fortsat ikke adressere udbakken i min emailklient.

Glædelig Jul og Godt Nytår til alle.

Karsten Madsen
CONTRIBUTOR **

af Karsten Madsen

Ahhhh. En prås gik lige op for mig.

Jeg kan huske en anden fejl i Summa, på præinstallerede pc'er altså de pc'er som har en præinstallereret Windows og ikke en dansk man læser ind selv.

Her gjaldt det kommaproblem.

Jeg løste det hos kunder ved  at gå ind i Kontrolpanel / Internationale indstillinger / Fanebladet Format / Vælge Dari (ja Dari) / OK / vælge Danmark og OK igen.

Det løste kommaproblemet, måske løser det også MAPIproblemet.

MAPI-engine virker nemlig med kommaseparation.

Allan Andersen
CONTRIBUTOR ***

af Allan Andersen

Hej Flemming J-K m.fl.

Nej - ingen har hidtil kunnet hjælpe med en permanent, og allesteds fungerende, løsning.

MEN, men, men: I mellemtiden har jeg så konstateret at en ny-installeret (ældre) bærbar, opsat med præcis samme software som min kontor-pc, dvs. Win7, Summa 4.40, MS Office 365 og Thunderbird gerne sender pdf-dokumenter som email direkte fra Summa. Den ny-installerede bærbare KAN altså bruge eksakt samme MAPI-kommunikation som ellers giver fejl på min kontor-pc.

Uanset at såvel "nørderne" (sønnen læser IT på Aarhus Universitet) som specialisterne fra bl.a. Visma, altså tilsyneladende ikke kan klarlægge hvad der forårsager denne MAPI-fejl, så kan en harddisk-formatering og komplet ny installation altså åbenbart løse problemet. 

Vennerne er dog kommet så langt, at de er relativt sikre på at problemet må relatere sig til data i pc'ens registreringsdatabase, som enten er forkerte, fejlplacerede, forældede eller udløbne. Det skulle følgelig få Summa til at adressere MAPI-funktionaliteten på en forkert måde (?), hvorved MAPI-"motoren" tilsyneladende sender et forkert "kald" til email-klienten, der resulterer i et svar fra emailprogrammet som er tilsvarende "i skoven" - og så får brugeren den besked at MAPI-modtageren ikke er aktiv.
Ja, det var en af de forklaringer jeg har fået.... 😉

Så det'e....