Mina produkter
Hjälp
Anonymous
Inte tillämpbar

Journal Posting

av Anonymous (Uppdaterad ‎23-12-2021 11:02 ( )

 

Hi ,

We were trying post journal lines for GL. When we use the option to execute the Journaltransaction and  we get 400 error - see below image.

sneebasree_1-1640253401399.png

 

Please suggest what can be the missing part here.

{
"batchNumber": {
"value": "string"
},
"hold": {
"value": true
},
"transactionDate": {
"value": "2021-12-23T04:28:07.757Z"
},
"postPeriod": {
"value": "string"
},
"financialPeriod": {
"value": "string"
},
"ledger": {
"value": "string"
},
"currencyId": {
"value": "string"
},
"exchangeRate": {
"value": 0
},
"autoReversing": {
"value": true
},
"description": {
"value": "string"
},
"controlTotalInCurrency": {
"value": 0
},
"createVatTransaction": {
"value": true
},
"skipVatAmountValidation": {
"value": true
},
"transactionCode": {
"value": "string"
},
"transactionDescription":{

"value":"DEFERRED TAX"
},
"branch": {
"value": "1"
},
"overrideNumberSeries": {
"value": true
},
"journalTransactionLines": [
{
"operation": "Insert",
"lineNumber": {
"value": 0
},
"accountNumber": {
"value": "xxxx"
},
"subaccount": [

{
"segmentId": 1,
"segmentDescription": "avdeling",
"segmentValue": "0",
"segmentValueDescription": "seg0"
},
{
"segmentId": 2,
"segmentDescription": "Leverandør",
"segmentValue": "0",
"segmentValueDescription": "None"
},
{
"segmentId": 3,
"segmentDescription": "enheter",
"segmentValue": "0",
"segmentValueDescription": "None"
}

],
"project": {
"id": "X",
"description": "Non-Project Code."
},
"TaxCategoryID":{
"value":string
},

"projectTask": {
"id": "string",
"description": "string"
},
"referenceNumber": {
"value": "string"
},
"transactionDescription": {
"value": "string"
},
"debitAmountInCurrency": {
"value": 0
},
"creditAmountInCurrency": {
"value": 0
},
"vatCodeId": {
"value": "string"
},
"vatId": {
"value": "string"
},
"branch": {
"value": "1"
},
"uom": {
"value": "string"
},
"quantity": {
"value": 0
}
}
]
}

 

1 SVAR 1
anna_swic
VISMA

av anna_swic

Hi @Anonymous 

I am not sure if your question is related to EasyCruit. What product are you using?
If your question is related to Visma EasyCruit, please contact our support at support.easycruit@visma.com and our support team will help you!

Have a nice day and Happy Holidays!

Få uppdateringar på det här inlägget i din inkorg

Klicka på de tre prickarna till höger i inlägget/artikeln och välj Prenumerera.

Läs mer om prenumeration här