annuller
Viser resultater for 
Søg i stedet efter 
Mente du: 
Mine områder

Log på eller tilmeld dig som ny bruger

for automatisk at få relevante områder

Jeg får besked om, at Mamut ikke får kontakt med SQL Serveren på enkeltbruger installation

28-01-2014 24:31
  • 0 Svar
  • 0 ros
  • 280 Visninger
Ved opstart af Mamut kommer der en meddelelse om, at der ikke er kontakt med SQL Serveren, selvom Mamut og SQL Serveren er installeret på den samme computer. Dette skyldes enten, at SQL-tjenesten ikke er startet, eller at Mamut ikke får lov til at koble til den.


Årsag 1: Mamut.ini kan ikke redigeres eller indeholder ikke alt den skal
Dette skyldes, at en installation opretter en ny Mamut.ini. Nogle gange kan denne ikke redigeres af Mamut ved opstart. Løsningen er da at slette denne file og så starte Mamut på ny.
I Windows XP ligger filen under C:\Documents and settings\All users\Public Mamut\Mamut.
I Windows 7, Vista og Windows Server 2008 ligger filen under C:\Brugere\Fælles\Public Mamut\Mamut (C:\Users\Public\Public Mamut\Mamut).
Efter Mamut.ini er slettet, kan Mamut startes og de normale valg ved første opstart kommer op.

 

Årsag 2: Mamut får ikke lov til at kontakte SQL-serveren
Dette skyldes normalt, at Mamut spærres af firewallen. Gå ind i firewallen på computeren og angiv, at mamut.exe og mdatatools.exe har fuld adgang til internettet. Deaktiver eventuelt firewallen og test.


Årsag 3: SQL-tjenesten kunne ikke starte på grund af firewallen
Der kan være forskellige årsager til dette, men det skyldes ofte, at firewallen spærrer adgangen til netværksprotokollerne.
Gå ind i firewallen på computer og giv Sqlservr.exe fuld adgang. Se også denne artikel.

 

Årsag 4: Mamut finder ikke den lokale SQl -server på enkeltbruger installation
Dette problem kan opstå hvis der er problemer med netværksopsætningen i Windows eller navnet på maskinen er ændret.

Dette kan løses på følgende måde:

  1. Start Windows stifinder og gå til følgende mappe: C:\Documents and Settings\All Users\Public Mamut\Mamut. I Vista, Windows 7 og Windows Server 2008 er stien C:\Users\Public\Public Mamut\Mamut.
  2. Åben filen Mamut.ini indsæt linjen Server=(local). Hvis du har en linje med Server=, skal denne ændres til at pege mod (local).
  3. Luk og gem Mamut.ini.

 

Årsag 5: SQL-tjenesten kan ikke benytte netværksprotokollerne i Windows
Dette kan opstå, hvis firewallen/ antivirus spærrer for adgangen til netværksprotokollerne, eller der er noget galt med disse. Hvis Mamut bare skal køre på én computer, kan du sætte SQL Serveren til ikke at bruge netværk.

Det gøres på følgende måde:

  1. Gå ind på Start - Programmer - Microsoft SQL Server 2005 - Configuration Tools - SQL Server Configuration Manager.
  2. I venstre vindue åbner du gruppen SQL Server 2005 Network Configuration.
  3. Klik så på Protocols for MAMUT.
  4. I højre vindue kontrollerer du, at Shared Memory, Named Pipes og TCP/IP er aktiveret (enabled) og at VIA er deaktiveret (disabled).
  5. Højreklik på TCP/IP og vælg Disable.
  6. Højreklik på Named Pipes og vælg Disable.
  7. Klik så på SQL Server 2005 Services.
  8. Højreklik på SQL Server (MAMUT), og vælg Start eller Restart.


Tjenesten SQL Server (MAMUT) skal nu starte, og Mamut skal fungere.