avbryt
Viser resultater for 
Søk heller etter 
Mente du: 
Mine områder

Logg inn eller registrer en ny bruker

for å automatisk få tildelt relevante områder i Mine områder.

Jeg får beskjed om at Mamut ikke får kontakt med SQL Server på enbruker installasjon

20-06-2013 21:05 (Sist oppdatert 14-10-2019)
  • 0 Svar
  • 0 Liker
  • 7757 Visninger

Ved oppstart av Mamut kommer det melding om at det ikke er kontakt med SQL Server selv om Mamut og SQL Server er installert på samme maskin. Dette kommer enten av at SQL-tjenesten ikke har startet, eller at Mamut ikke får lov til å kontakte den.

Årsak 1: Mamut.ini kan ikke redigeres eller inneholder ikke alt den skal
Dette kommer av at en installasjonen oppretter en ny Mamut.ini. Av og til kan denne ikke redigeres av Mamut ved oppstart. Løsningen er da å endre filnavnet og så starte Mamut på nytt.
I Windows XP ligger filen på C:\Documents and settings\All users\Public Mamut\Mamut.
I Windows 7, Vista og Windows Server 2008 ligger filen på C:\Brukere\Felles\Public Mamut\Mamut (C:\Users\Public\Public Mamut\Mamut).
Etter at Mamut.ini er slettet kan Mamut startes og de vanlige valgene for første oppstart kommer opp.

Årsak 2: Mamut får ikke lov til å kontakte SQL-server
Dette kommer vanligvis av at Mamut sperres av brannmur. Gå inn i brannmur på maskinen, og sett at mamut.exe og mdatatools.exe har full tilgang til Internett. Skru eventuelt av brannmuren, og test.

Årsak 3: SQL-tjenesten kunne ikke starte på grunn av brannmur
Dette kan ha litt forskjellige årsaker men kommer ofte av at brannmur sperrer tilgang til nettverksprotokollene.
Gå inn i brannmuren på maskinen, og legg inn at Sqlservr.exe skal ha full tilgang. 

Årsak 4: Mamut finner ikke den lokale SQL-server på enbrukerinstallasjon
Dette kan oppstå hvis det er problemer med nettverksoppsett i Windows eller maskinnavn i Windows er endret.

Dette løses slik:

  1. Start Windows Utforsker og bla til C:\Documents and Settings\All Users\Public Mamut\Mamut. I Vista, Windows 7 og Windows Server 2008 er stien C:\Users\Public\Public Mamut\Mamut.
  2. Åpne Mamut.ini og sett inn linjen Server=(local). Hvis du har en linje med Server=, endre denne til å peke til (local).
  3. Lukk og lagre Mamut.ini.

 

Årsak 5: SQL-tjenesten kan ikke benytte nettverksprotokollene i Windows
Dette kan oppstå hvis brannmur/antivirus sperrer tilgang til nettverksprotokollene eller det er noe galt med disse. Dersom Mamut bare skal kjøre på én maskin, kan dere sette SQL Server til å ikke bruke nettverk.

Dette gjøres slik:

  1. Gå inn på Start - Programmer - Microsoft SQL Server 2005/2008 R2 - Configuration Tools - SQL Server Configuration Manager.
  2. I venstre vindu, ekspander gruppen SQL Server Network Configuration.
  3. Klikk så på Protocols for MAMUT.
  4. I høyre vindu sjekk at Shared MemoryNamed Pipes og TCP/IP er aktivert (enabled) og at VIA er deaktivert (disabled).
  5. Høyreklikk på TCP/IP, og velg Disable.
  6. Høyreklikk på Named Pipes, og velg Disable.
  7. Klikk så på SQL Server Services.
  8. Høyreklikk på SQL Server (MAMUT), og velg Start eller Restart.
  9. Start Windows Utforsker og bla til C:\Documents and Settings\All Users\Public Mamut\Mamut. I Vista, Windows 7 og Windows Server 2008 er stien C:\Users\Public\Public Mamut\Mamut.
  10. Åpne Mamut.ini og sett inn linjen Server=(local). Hvis du har en linje med Server=, endre denne til å peke til (local).
  11. Lukk og lagre Mamut.ini.

Tjenesten SQL Server (MAMUT) skal nå starte, og Mamut skal fungere.

Aktuelt brukertips