My Products

Swagger broken since approximately February 2.

by guidol (Updated ‎10-02-2023 08:11 by guidol )

Related to and


There are several issues it seems, part of which leads to a largely full production stop:


Issue 1 - Swagger broken

The Swagger at opens, but seems to have changed largely. The following entries are completely missing:

- ipp-company-id

- ipp-application-type

The Swagger lists version 9.33 of unknown date. The missing of ipp-company-id ensures that practically all Invantive Cloud users are seeing either HTTP 400 Bad Requests with an error like:


Invalid parameter exception: ipp-company-id (12002_12002_7b28d6d8-104b-4acc-991b-e5290bde8fdb)


when their cached copy of the Swagger is not updated, or getting errors when retrieving data from since there is no longer a way with the current driver of Invantive SQL to access the APIs providing the company (called "partition" in Invantive SQL).


The missing of ipp-company-id might be related to the early December announcement that the VNI will be deprecated during 2023 (no specific date mentioned) (source: The linked PDF in that article specifies on page 19 that ipp-company-id will be dropped in 2023.


Impact: Blocking; the impact is that almost all use on Invantive Cloud has come to a halt.

Question: Is it possible to revert the changes on the Swagger metadata?



Issue 2 - Swagger UI broken


The Swagger UI works unrealiably it seems. On my PC (Windows, Chrome), a 404 error occurs on service-worker.js


Error during service worker registration: TypeError: Failed to register a ServiceWorker for scope ('') with script (''): A bad HTTP response code (404) was received when fetching the script.



However, a co-worker on another Windows PC with Chrome has a new filename continuously on main*.js which fails and returns an empty page. This may explain problem on


He is located in same city as I am. His error:



The page displays however. Authorize works, but leads to a weird error:



The fact that authorization works is proven that does not require authentication when opened after the weird error.



Impact: low; we can live without Swagger UI.


Question: None.



Issue 3 - Release notes incorrect


The release notes don't mention that ipp-company-id would be dropped (source: The point of financial periods is known; it was for one of the older users, but there is no other breaking changes listed.


Impact: low; as long as intended situation known we can fix it.

Question: would be great when release notes would be updated when switch on OAuth is actually required with this release.


by Trygve Storrønningen1

Thank you 🙂


Removing cookies solved it in Chrome, not in Edge. 
And I miss response from Visma here.

Don't know why, but had to manually delete records for from the sqlite cookies file in AppData\Local\Microsoft\Edge\User Data\Default\Network
Now Issue 2 is working on both Chrome and Edge.

by Trygve Storrønningen1

Visma, any news on this? It was posted 6 days ago, and we also experience Issue 2.



by guidol (Updated ‎16-02-2023 09:37 by guidol )

We have solved issue 1 by switching back to one of the old Swagger JSON files. That fixed it for now. With Visma Connect upcoming, there are probably more issues ahead so we will again in a few months how the Swagger evolves. When you don't have it, I can send an old swagger to you.


Issue 2 can be seemingly be solved by removing cookies.