cancel
Showing results for 
Search instead for 
Did you mean: 
My Areas

Sign in or create account

to get a personalized navigation.

guidol
CONTRIBUTOR **

Wrong tokenUrl and authorizationUrl in Swagger

by guidol

Recently, the Swagger on https://integration.visma.net/API-index/doc/swagger has been updated. Since then, the tokenUrl and authorizationUrl point to the wrong server. The current definition points to "

https://alb.vni.prodaws.visma.com" (I guess an AWS Load Balancer), instead of the correct "https://integration.visma.net".
 
Our software solely depends on the Swagger definition to determine the data model and OAuth endpoints. Multiple large accountants are currently down.
 
Please fix the Swagger as soon as possible.
11 REPLIES 11

by Magnus Johnsen

Hi,

 

We'll report this to the developers and get back to you. 

guidol
CONTRIBUTOR **

by guidol

Hi Magnus,

 

Thanks for the feedback. Is there any information on when this will be resolved?

 

Regards

by Magnus Johnsen

As of now, we cannot give a time to resolve, a case has been opened and we are wating for more information.

by Magnus Johnsen (Updated ‎06-08-2020 12:59 by Magnus Johnsen VISMA )

While we are waiting for a solution as a sidenote/workaround, you only need to authorize once with your API user as there is no time limit/need to refresh the token in Visma.Net authorization.

 

If you have authorized once, for all companies the user has access to, it will be valid, as it is written in the documentation that is provided in the ISV certification program.

guidol
CONTRIBUTOR **

by guidol

Thanks for the suggestion.

 

The problem with your suggestion is twofold:

- New users don't have tokens yet, so they have to use this flow.

- Some of our products work client-side. We do not save refresh tokens there for security reasons. I would also suggest Visma to add the implicit grant flow which is more suitable for client-side applications.

 

So in short: your suggestions are unfortunately not going to work for our current users. We really need the Swagger updated.

by Magnus Johnsen

Hi,

Rrgarding ideas for Visma.Net Financials, we have a section where you can post these: Ideas

There improvements can be posted and voted on by the community.

 

As mentioned, for now we are waiting for the development team to have a look at this issue, however the addresses provided in the documentation(attached here again for ease) are still valid.

guidol
CONTRIBUTOR **

by guidol

Hi Magnus,

 

I don't doubt the hand-written documentation is correct at this point in time. However, Visma has provided a technical documentation in the form of a Swagger definition that now deviates from the hand-written documentation.

 

Do you want to say that we should only use the hand-written documentation for this type of information, or do you think the Swagger should (also) be correct at all times?

Accepted solution
Magnus Johnsen
VISMA

by Magnus Johnsen

Hi,

 

A fix for this has been released, please have another look and let us know if there is still an issue.

 

Thank you. 

guidol
CONTRIBUTOR **

by guidol

Apologies for delay; mails got lost in spam.

 

All customers up again. Thanks for assistance!

Sjoerd Klijn
PARTNER

That would be nice. We got the same problem!

Our customer Joanknecht is having serious issues because of this in their daily business. Please solve this issue asap. thank you eServiceware 

eServiceware, uw Visma.net Expert Center