cancel
Showing results for 
Search instead for 
Did you mean: 
My Areas

Sign in or create account

to get a personalized navigation.

eriklarsen
CONTRIBUTOR *

Contact API endpoint

by eriklarsen (Updated ‎08-07-2020 12:39 by eriklarsen )

Hi,

 

GET https://integration.visma.net/API/controller/api/v1/contact always return empty set .

 

and

 

GET https://integration.visma.net/API/controller/api/v1/contact/{contactId} always return "Id not found".

 

Bearer token and "ipp-appoication-type" and "ipp-company-id" headers are set.

 

What could cause this behaviour?

 

Reason we want to use the contact endpoint, is because we are trying to get hold of phone number for customer/contact for CustomerInvoice. Previously, this was included in "CustomerInvoice" endpoint, but then it disappeared, so we started using the "Customer" endpoint, but seems like it has disappeared from there too. If exporting through web application, phone number is included.

 

Br,
Erik

 

2 REPLIES 2
Accepted solution
Yıldırım
VISMA

by Yıldırım

Hello, 
in addition to information that is shared about Contact Endpoint, Invoice Contact > Phone field can be fetched through Customer Invoice Endpoint. 

Contact Phone can be either automatically populated in the invoice based on main contact field that can be found in Customer Card or can be edited by overriding contact info in the Invoice.

1-Customer Card : Main Contact : Phone1 
CustomerCard.png

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

2) Customer Invoice: Override Contact : Phone1
custinv.png

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

This value will be returned in GET > Customer Invoice > 

"invoiceContact": {
      "contactId": 0,
      "businessName": "string",
      "attention": "string",
      "email": "string",
      "phone1": "string",
      "overrideContact": true
    },

by Magnus Johnsen

Hi,

 

Could you please make sure the contacts tab under "Customer"(ScreenId=AR303000) is populated for at least one customer and that you are targeting the correct company.

 

2020-07-08 12_44_50-Customers.png

 

We can not reproduce this, in our local company this shows up when getting all contacts, the contact ID to use for specific search is found at the bottom:

 

[
    {
        "displayName""Von Test Test, Dr.",
        "active"true,
        "title""Doctor",
        "firstName""Test",
        "lastName""Von Test",
        "businessAccount""10000  ",
        "businessAccountType""Customer",
        "sameAsAccount"false,
        "address": {
            "addressId"3006,
            "addressLine1""Testvägen 13/3",
            "postalCode""0010",
            "city""OSLO",
            "country": {
                "id""NO",
                "name""NORGE"
            },
            "county": {
                "id""0301",
                "name""OSLO"
            }
        },
        "email""testVonTest@Drtest.com",
        "web""test.test.com",
        "phone1""040404",
        "phone2""050505",
        "phone3""060606",
        "fax""070707",
        "contactMethod""Any",
        "doNotCall"false,
        "doNotFax"false,
        "doNotEmail"false,
        "doNotMail"false,
        "noMassMail"false,
        "noMarketing"false,
        "lastModifiedDateTime""2019-11-29T12:21:38.877",
        "contactId"3024
    }
]