My Products
Jasper Heus

Retrieve budget not getting any data

by Jasper Heus

I'm trying to retrieve the following data via the API:



 with the following API call:

But the response stays empty with a 200 OK result:



The ledger seems to be correct but I'm not sure the branche is. But all other possible values do not change a thing (name, organizationId, corporateId). The response stays empty. Also adding a year financialYear does not change a thing.


As an extra reference the branche output, Ledger is marked in the screencap, so I think that is correct.




Any idea what I'm doing wrong?



by DataVacuum

Curious to hear why Branch has to be '5' since the branch number in other data always refers to 1 in my get-requests. Solution solved my problem though.


by Yıldırım (Updated ‎17-06-2021 12:57 by Yıldırım VISMA )

Organization/Branch ID may vary depending on the company, how many branches they have etc, therefore the ID value is not static. The reason for suggesting to trying out "5" is because the print screen you've shared, where OrganisationID  is "5"


2021-06-17 12_47_37-Window.png

Accepted solution

by Yıldırım (Updated ‎26-05-2021 10:12 by Yıldırım VISMA )


could you try to send "5" for the "Branch" parameter ?     


(?financialYear=2021) Should also be included.

Jasper Heus

by Jasper Heus

That did the trick. That combination was one I did not try yet. It is odd though that if I remove the financialYear parameter the result is also empty but the parameter is not manditory.


by Yıldırım

Good to hear👍 Indeed, there seems to be an issue with parameter definitions.

Endpoint actually expects them as mandatory parameters but doesn't return an error when they're not provided. We'll check this out.

by sanderdercksen

In your screenshot the budget is entered in the ledger "BUDGET", however in your call you are referring to the "WERKELIJK" ledger...? 



Jasper Heus

Also tried that, but that did not do anything. I Also thought that because the ledger in the 2nd screenshot only returns WERKELIJK that should at least give some data.

Could there be any relation between the API only returning WERKELIJK as ledger being part of the branche? Because if I try to retrieve all Ledgers I get more results (including BUDGET and WERKELIJK)

Can you try to remove the Branch filter from your call?