My Products
Help
FrankdeWeger
CONTRIBUTOR *

Using start / end date in the API when creating a new invoice

by FrankdeWeger (Updated ‎30-03-2021 10:49 by Yıldırım VISMA )

Hello,

 

We're trying to set the start- and the enddate using CustomerInvoiceV2 using the following JSON (the full payload is in the attachment):

 

 

 

  "startDate": {
    "value": "2021-03-08T15:28:24.720Z"
  },
  "endDate": {
    "value": "2021-03-08T15:28:24.720Z"
  }

 

 

 

However, when we add this in the payload, we get the following error:

 

 

 

Error creating document. Handle(Visma.net.ERP.Api.AR.CommandModel.Commands.ChildCommands.ChangeInvoiceStartDateCommand cmd) not found

 

 

 

Is there a way to set the start- and the enddate using the API?

 

Regards,

 

Frank

4 REPLIES 4
Accepted solution
Yıldırım
VISMA

by Yıldırım
Yıldırım
VISMA

by Yıldırım (Updated ‎08-03-2021 18:08 by Yıldırım VISMA )

Hello, 

we confirm the issue which is occurring when the "startDate" and "endDate" used in the POST Customer Invoice V2 Endpoint payload either in the Invoice Lines Array or Document Body level.

 

 "startDate": {
        "value": "2021-03-08T16:23:24.691Z"
      },
      "endDate": {
        "value": "2021-03-08T16:23:24.691Z"
      },



ERP UI > Customer Invoice > Financials Details > Invoice Period Dates
(API Payload : Document Level)
POST_CustomerInvoice_v2_start_end_date_finDetails.png

ERP UI > Customer Invoice > Document Details (API Payload: InvoiceLines)
POST_CustomerInvoice_v2_start_end_date.png

The same payload works as expected in POST Customer Invoice V1 Endpoint so that we recommend using V1 for this operation until the issue has been sorted out. Thank you for reporting this to us.

FrankdeWeger
CONTRIBUTOR *

by FrankdeWeger

Hi Yildirim,

 

Thanks for your swift reply. According to https://integration.visma.net/API-index/ V1 will be removed in May this year, could you give me a rough estimate on when this will be fixed in V2?

 

Regards,

 

Frank

Yıldırım
VISMA

by Yıldırım

Hello Frank,

 

Details haven't been emerged yet, therefore, we're unable to share a specific version information at the moment, but this has been prioritized. V1 Endpoint won't be disabled before the issue is resolved in the V2.

Thanks.